Skip to main content

Instructions for use of NX4 Player (beta) - Mac OS X 10.7 or higher users should read this!

We have posted instructions and configuration files for using the NX4 Player (beta) for connecting to the SSG. More information here.